Gtk3 themes broken due to latest Gtk3 update
Confirmed, Issue can be reproduced, NormalPublic

Description

Since Gtk 3.20 all/most external themes are broken except Adwaita, HighContrast and Raleigh.

What's failed: no buttons or menus are drawn.

In Synaptic the toolbar buttons disappeared in Adwaita, too.

While web searching I found similar problems:
No Gtk+3 support for Breeze theme (https://bugs.kde.org/show_bug.cgi?id=361066, https://bugs.archlinux.org/task/48871)

Perhaps I find a patch which fixes or disarm this issue: https://bugs.freedesktop.org/show_bug.cgi?id=94887
I will give it a shot to see what's happen ...

  • Thomas --

Details

Upstream bug
#824891 - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=824891
gonzomcgraw added a comment.EditedJun 10 2016, 1:09 AM

Perhaps I find a patch which fixes or disarm this issue: https://bugs.freedesktop.org/show_bug.cgi?id=94887
I will give it a shot to see what's happen ...

Nope ... this patch (https://git.gnome.org/browse/gtk+/commit/?h=gtk-3-20&id=6144b2276c7298040c080f85ffa83afbe1257c54) was dropped in gtk+3.0 (3.20.2-1) because it was in this release already :(

I saw a gorgeous new GTK+3 Breeze theme in action at a KDE sprint this week :-)
So at least for Plasma we might have a solution (that should go into Tanglu 4.0 (Dasyatis kuhlii) soo though, when there is a release of the theme or reasonably bug-free Git snapshot can be taken).

ximion closed this task as "Unknown Status".Jun 10 2016, 1:50 PM
ximion reopened this task as "Confirmed".
ximion triaged this task as "Normal" priority.