sddm: doesn't start after boot
Closed, ResolvedPublic

Description

After an update from Tanglu 2 with kdm (sddm disabled) to Tanglu 3 with sddm as display manager, sddm fails to start after system boot.

When logging in as user in a tty session a manual start of sddm or startx starts KDE5 / plasma without problems.

The problem was discussed in the forums: http://tangluusers.org/thread/tanglu-3-kde-session-doesnt-start-automatically-67

It seems to be known at Debian too: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=794123

ximion set Upstream bug to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=794123.Aug 13 2015, 11:57 AM
ximion triaged this task as "Normal" priority.Aug 14 2015, 12:58 PM
ximion added a subscriber: ximion.
theenduser added a subscriber: theenduser.EditedAug 17 2015, 11:12 AM

I did a fresh install and I'm experiencing the same issue. In the live session I also had to manually start the session.

jeno added a subscriber: jeno.Aug 26 2015, 1:33 PM

Also this bug report could be of interest

We will likely ship an updated version of SDDM soon, I just pinged upstream about making a release.
If the issue persists with the new version, we will take this upstream and report a new bug there.

ximion changed Upstream bug from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=794123 to https://github.com/sddm/sddm/issues/371.Aug 31 2015, 7:06 PM
ximion added a comment.Sep 3 2015, 4:45 PM

Okay, there will likely be another SDDM release this weekend, which has really good chance to have this issue fixed or at least improve error reporting.
I will test it here and likely backport it to Tanglu 3.0 (Chromodoris willani).

ximion changed the task status from "Open" to "Incomplete".Sep 6 2015, 12:19 AM

Please test if the package sddm/​0.12.0-0tanglu0.1 resolves the issue for you (available in the -updates sources).

ximion added a comment.Sep 6 2015, 1:50 AM

Found an issue in the package, fortunately it was caught before public release. So the current, tested sddm release is now sddm/​0.12.0-0tanglu0.3.

STiAT added a subscriber: STiAT.EditedSep 6 2015, 3:06 PM

sddm/0.12.0-0taglu0.3 still has the same issue as all other versions since 0.11.0-3tanglu1.1, so the last working version is 0.11.0-3tanglu1.1.

ximion added a comment.EditedSep 6 2015, 3:27 PM

Does

sudo chmod +x /etc/sddm/Xsession

solve the problem for you?
If that fixes it, you only experienced the error because you had the broken package installed previously.

ximion claimed this task.Sep 6 2015, 3:47 PM
STiAT added a comment.Sep 6 2015, 9:06 PM

Yep, that fixed it.
Why not put that into the post-install just to be safe?

ximion added a comment.Sep 6 2015, 9:10 PM

It's already in there, you just don't have the latest version of the package ;-)
Were you affected by this bug as well? ("sddm fails to start after system boot") Because if this issue is resolved, we could probably close the bug report.

STiAT added a comment.EditedSep 7 2015, 1:09 AM

sddm/chromodoris-updates,now 0.12.0-0tanglu0.3 amd64 [installed,automatic]

seems like the latest version. I've always upgraded and downgraded between the "current" version and 0.11.0-3tanglu1.1 using dpkg -i <package>.
0.11.0-3tanglu1.1 always worked, I always just re-installed this one to get back to my desktop.

So well ... I was on 0.11.0.3-tanglu1.1, and after installing 0.12.0-0taglu0.3 it still didn't work, which should be the "safe" upgrade path.

So no, the upgrade between 0.11.0.3 and 0.12.0 still does not work properly!

And yes, I was affected by the upgrade of Tanglu 2 to Tanglu 3 by sddm not starting, but that one is long ago solved (sorry for hijacking the bug report :-)).

ximion added a comment.Sep 7 2015, 1:17 AM
In T152#1322, @STiAT wrote:

sddm/chromodoris-updates,now 0.12.0-0tanglu0.3 amd64 [installed,automatic]

seems like the latest version.

It isn't ;-) The real latest version isn't published though, that's why you don't see it in the archive yet.
See the archive acceptance mail and the package's build status. The builders are on heavy load at time, but will prefer building the package. So, it will likely only take a few hours until it's in the -updates archive. Uploads to the updates suites are much slower than updates for the development suites.

And yes, I was affected by the upgrade of Tanglu 2 to Tanglu 3 by sddm not starting, but that one is long ago solved (sorry for hijacking the bug report :-)).

So, we can close this bug report as resolved? (would still be great to hear back from the original reporter)

ximion closed this task as "Resolved".Sep 8 2015, 11:54 PM

Marking as fixed, please reopen in case the issue still exists.

STiAT added a comment.Sep 12 2015, 2:45 PM

Again, sddm does not boot after the 0.12.0-0tanglu0.5 update. Again had to chmod Xsession manually to make it start.

The package does still not deliver a proper Xsession permission and/or does not do that in post installation.

STiAT reopened this task as "Open".Sep 12 2015, 2:52 PM

Re-Opening the bug (see the comment above).

Wow... That shouldn't happen, I'll look into it...

ximion raised the priority of this task from "Normal" to "High".Sep 12 2015, 4:12 PM
ximion raised the priority of this task from "High" to "Unbreak Now!".Sep 12 2015, 4:39 PM

(actually, this is highest priority, since it's a regression in a stable release)

Do you have Plymouth installed?
Could you please check if sddm/0.12.0-1tanglu0.1 (due to be installed into the archive) fixes the issue for you?

ximion closed this task as "Resolved".Sep 12 2015, 8:18 PM

Tested in VM and on metal, no issues found when upgrading sddm or using the current version 0.12.0-1tanglu0.1.

I don't know how to get the package without the mirror providing it. Will check back as soon as I get it by the mirror :-).

The mirror should need 6h at max to provide the package - highly likely it's less time.

I still didn't get it by the mirror ... strange (using tanglu.org mirror).

STiAT added a comment.EditedSep 14 2015, 12:02 AM

My mistake, installed it yesterday 17:32 already and didn't realize it (it was the time when i re-installed the package and did the chmod on my own).

Re-Installed sddm: Tested, works. Thanks for fixing it Matthias.

STiAT added a comment.Nov 12 2015, 7:04 PM

I'm on Arch now (Tanglu got too unstable for my daily use), but I wanted you to know that after a later sddm update this re-appeared, but it was not the chmod on the xsession but seemed some other issue.