Breeze-Dark: Panel remains white after changing theme
Open, NormalPublic

Description

Ed Sheridan wrote on 23. April 2015 01:02:

Package: plasma-desktop

K start menu - Settings - System Settings - Appearance - Workspace theme - Desktop Theme -> change from "Breeze" to "Breeze Dark" - Apply

>

KDE logo in start menu, Keyboard Layout, Clipboard Contents, Networks and clock icons disappear.

importbot added a subscriber: importbot.

Matthias Klumpp wrote on 27. May 2015 01:01:

Is this still an issue with the Plasma 5.3 packages in Chromodoris?

Ed Sheridan wrote on 04. June 2015 02:22:

Haven't checked yet, sorry.

ximion closed this task as "Resolved". · Mon, Jul 13, 3:33 AM
ximion claimed this task.

Assuming that this issue is fixed - Plasma has been updated to 5.3 meanwhile anyway.
If the issue persists, please reopen this task.

importbot closed this task as "Resolved".Jul 28 2015, 11:30 AM
Bart added a subscriber: Bart.Aug 3 2015, 3:17 PM
Bart reopened this task as "Open".Aug 3 2015, 3:23 PM

I confirm the issue still persists with Plasma 5.3 after installing Chromodoris (RC2).

ximion edited the task description. (Show Details)Aug 3 2015, 3:39 PM
ximion set Upstream bug to https://bugs.kde.org/show_bug.cgi?id=345957.
ximion removed a subscriber: importbot.
ximion added a subscriber: ximion.

Looks like this is an upstream bug in KDE with wrong icon inheritance...

ximion removed Upstream bug.Aug 3 2015, 6:15 PM

I can reproduce the bug, the other UI elements are not colored correctly.... Strange.

ximion changed the title from "Task bar items disappear when changing theme" to "Breeze-Dark: Panel remains white after changing theme".Aug 3 2015, 6:25 PM
ximion set Upstream bug to https://bugs.kde.org/show_bug.cgi?id=347143.
Bart added a comment.Aug 3 2015, 7:10 PM

Following the discussion of upstream bug https://bugs.kde.org/show_bug.cgi?id=347143, these steps solved the problem for me:

System Settings - Appearance - Desktop Theme -> change theme to "Breeze dark" -> Apply
System Settings - Desktop Effects -> switch off "Background contrast" and "Blur" -> Apply
System Settings - Desktop Effects -> switch back on "Background contrast" and "Blur" or hit "Defaults" -> Apply
(in the last step, only switching back on "Blur" is mandatory)

As expected I get a solid dark panel with dark kickoff, white clock and white K-menu-icon.

It unfortunately is too late to fix this for chromodoris, but we will have it fixed with dasyatis, or maybe provide an update via the updates repository.

Bart removed a subscriber: Bart.Aug 3 2015, 7:22 PM